OPatch failed with error code 73 ??

I have already applied the One-Off Patch 5648872 on my Test environment, which is same(i thought so) like my Prod. Tough it went smooth in the test, it wasn’t the same in the prod. It failed !!

And the Opatch log said:
#Opatch 10.2.0.3.0
Patching component oracle.rdbms, 10.2.0.3.0…
INFO:Updating archive file “/u01/app/oracle/product/10.2.0/db_1/lib/libserver10.a”  with “lib/libserver10.a/kks.o”
INFO:Start Archive Action at Wed Jul 23 19:08:30 JST 2008
INFO:Finish Archive Action at Wed Jul 23 19:08:42 JST 2008
INFO:Finish modifying the system at Wed Jul 23 19:08:42 JST 2008
INFO:ApplySession adding interim patch ‘5648872’ to inventory
INFO:Start saving patch to inventory at Wed Jul 23 19:08:42 JST 2008
INFO:Finish saving patch to inventory at Wed Jul 23 19:08:55 JST 2008
INFO:
Verifying the update…
INFO:Inventory check OK: Patch ID 5648872 is registered in Oracle Home inventory with proper meta-data.
INFO:   verifying 1 archive files.
INFO:     Archive failed: failed to update “/u01/app/oracle/product/10.2.0/db_1/lib/libserver10.a” with updated “/export/home/oraprd/5648872/files/lib/libserver10.a/kks.o”
INFO:Failed file pair information (archive)::
INFO:Source file name is : /export/home/oraprd/5648872/files/lib/libserver10.a/kks.o,  size is : 210112
INFO:Destination file name (extracted from Oracle Home) is : /u01/app/oracle/product/10.2.0/db_1/.patch_storage/verify/archive/lib/libserver10.a/kks.o,  size is : 210116
INFO:SEVERE:OUI-67073:ApplySession failed: ApplySession failed in system modification phase… ‘Verification of patch failed: null’

INFO:OPatch will attempt to restore the system…
INFO:Restoring the Oracle Home…
INFO:Checking if OPatch needs to invoke ‘make’ to restore some binaries…
INFO:OPatch was able to restore your system. Look at log file and timestamp of each file to make sure your system is in the state prior to applying the patch.
INFO:Finishing ApplySession at Wed Jul 23 19:09:08 JST 2008
INFO:Total time spent waiting for user-input is 32 seconds.  Finish at Wed Jul 23 19:09:08 JST 2008
INFO:Stack Description: java.lang.Error: ApplySession failed in system modification phase… ‘Verification of patch failed: null’
INFO:StackTrace: oracle.opatch.ApplySession.processLocal(ApplySession.java:4339)
INFO:StackTrace: oracle.opatch.ApplySession.process(ApplySession.java:4722)
INFO:StackTrace: oracle.opatch.OPatchSession.main(OPatchSession.java:1113)
INFO:StackTrace: oracle.opatch.OPatch.main(OPatch.java:516)

And this pointed me to MetaLink Note:353150.1
(Subject:  OPatch Failing Validation Phase When Archiving Really Did Not Fail) and i had to download the latest opatch and restart the ‘opatch apply’ and it went smoothly giving me the warnings as expected.

#Opatch 10.2.0.4.3
Verifying the update…
INFO:Inventory check OK: Patch ID 5648872 is registered in Oracle Home inventory with proper meta-data.
INFO:   verifying 1 archive files.
INFO:Failed file pair information (archive)::
INFO:Source file name is : /export/home/oraprd/5648872/files/lib/libserver10.a/kks.o,  size is : 210112
INFO:Destination file name (extracted from Oracle Home) is : /u01/app/oracle/product/10.2.0/db_1/.patch_storage/verify/archive/lib/libserver10.
a/kks.o,  size is : 210116
WARNING:OUI-67124:Verification of ‘ar’ actions failed. This is a known issue for this platform. Please check the note 353150.1 on Metalink for the process to manually verify the files.
INFO:Files check OK: Files from Patch ID 5648872 are present in Oracle Home.
INFO:
The local system has been patched.  You can restart Oracle instances on it.

But why didn’t it fail in the Test environment?

#On Prod
$ cat /etc/release
                       Solaris 10 1/06 s10s_u1wos_19a SPARC
           Copyright 2005 Sun Microsystems, Inc.  All Rights Reserved.
                        Use is subject to license terms.
                           Assembled 07 December 2005
$

#On Test
$ cat /etc/release
                       Solaris 10 8/07 s10s_u4wos_12b SPARC
           Copyright 2007 Sun Microsystems, Inc.  All Rights Reserved.
                        Use is subject to license terms.
                            Assembled 16 August 2007
$

The Solaris on Prod is with update 1(s10s_u1wos_19a) and that on the Test is with update 4(s10s_u4wos_12b) and i guess SUN had fixed this ‘ar’ issue in update 4.

Advertisements

3 thoughts on “OPatch failed with error code 73 ??

  1. Pingback: Index « My confrontations with oracle

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s